Задания Алгоритм для конкретного исполнителя с фиксированным набором команд 32



Скачать 254.87 Kb.
страница15/23
Дата25.01.2018
Размер254.87 Kb.
Название файлаЗадания 6.docx
1   ...   11   12   13   14   15   16   17   18   ...   23
Повтори k раз

Команда1 Команда2 Команда3

Конец

означает, что последовательность команд Команда1 Команда2 Команда3 повторится k раз.

Чертёжнику был дан для исполнения следующий алгоритм:

Сместиться на (2, –7)

Повтори 6 раз

Сместиться на (0, 1) Сместиться на (–1, 1) Сместиться на (–2, 2)

Конец

Какую команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?

 

1) Сместиться на (–18, 24)



2) Сместиться на (18, –24)

3) Сместиться на (16, –17)

4) Сместиться на (–16, 17)

Ответ: 3


47. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в направлении движенияНаправо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что последовательность команд в скобках повторится k раз.

При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник?

 

1) Повтори 3 [Вперёд 50 Направо 20 Направо 25]



2) Повтори 3 [Вперёд 50 Направо 100 Направо 20]

3) Повтори 6 [Вперёд 50 Направо 10 Направо 20]

4) Повтори 6 [Вперёд 50 Направо 20 Направо 40]

Ответ: 2


48. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в направлении движения; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что последовательность команд в скобках повторится k раз.

При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный шестиугольник?

 

1) Повтори 6 [Вперёд 100 Направо 90]



2) Повтори 6 [Вперёд 100 Направо 9]

3) Повтори 6 [Вперёд 100 Направо 60 Направо 60]

4) Повтори 6 [Вперёд 100 Направо 20 Направо 40]

Ответ: 4


49. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в направлении движения; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:





Поделитесь с Вашими друзьями:
1   ...   11   12   13   14   15   16   17   18   ...   23


База данных защищена авторским правом ©danovie.ru 2017
обратиться к администрации

    Главная страница