Задания Алгоритм для конкретного исполнителя с фиксированным набором команд 32


Повтори 6 [Вперёд 5 Направо 30]



Скачать 254.87 Kb.
страница16/23
Дата25.01.2018
Размер254.87 Kb.
Название файлаЗадания 6.docx
1   ...   12   13   14   15   16   17   18   19   ...   23
Повтори 6 [Вперёд 5 Направо 30]

Какая фигура появится на экране?

 

1) незамкнутая ломаная линия



2) правильный треугольник

3) правильный пятиугольник

4) правильный шестиугольник

Ответ: 1


50. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в направлении движенияНаправо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:





Поделитесь с Вашими друзьями:
1   ...   12   13   14   15   16   17   18   19   ...   23


База данных защищена авторским правом ©danovie.ru 2017
обратиться к администрации

    Главная страница