Задания Алгоритм для конкретного исполнителя с фиксированным набором команд 32


Повтори 12 [Направо 45 Вперёд 20 Направо 45]



Скачать 254.87 Kb.
страница17/23
Дата25.01.2018
Размер254.87 Kb.
Название файлаЗадания 6.docx
1   ...   13   14   15   16   17   18   19   20   ...   23
Повтори 12 [Направо 45 Вперёд 20 Направо 45]

Какая фигура появится на экране?

 

1) квадрат



2) правильный двенадцатиугольник

3) правильный восьмиугольник

4) незамкнутая ломаная линия

Ответ: 1


51. Исполнитель Чертёжник перемещается на координатной плоскости, оставляя след в виде линии. Чертёжник может выполнять команду Сместиться на (a, b) (где a, b – целые числа), перемещающую Чертёжника из точки с координатами (x, y) в точку с координатами (x + a, y + b). Если числа a, b положительные, значение соответствующей координаты увеличивается, если отрицательные — уменьшается.

Например, если Чертёжник находится в точке с координатами (4, 2), то команда Сместиться на (2, –3) переместит Чертёжника в точку (6, –1). Запись





Поделитесь с Вашими друзьями:
1   ...   13   14   15   16   17   18   19   20   ...   23


База данных защищена авторским правом ©danovie.ru 2017
обратиться к администрации

    Главная страница